Deleting a post

Feb 4, 2011 at 9:38 AM

Hi there,

Just installed the UComment add-in for Umbraco on our site, fantastic work and exactly what we are looking for,  I put a "leave comment" on our home page, tried it and it worked fine, however when I went to delete the test comment i had left it did not delete.  I tried highlighting it and using "delete selected" and I also tried clicking the delete on the comment itself?  The dialog prompt appears but it doesnt seem to go anywhere.   Am I being silly?

Kind regards,

Andy

Feb 4, 2011 at 9:43 AM

Further testing shows that none of the link buttons within the comments dashboard control are working for me under FF or IE8.   I am using Umbraco 4.6 and the front end part of the control seems to be working fine.

A

Mar 8, 2011 at 7:28 AM

I can reproduce this problem, so youre not alone.

Mar 8, 2011 at 7:29 AM

Please vote for the issue tracker work item here http://ucomment.codeplex.com/workitem/5908

Mar 11, 2011 at 2:09 AM

Figured out what the issue is..

In Umbraco 4.6.1 (im running 4.7.0.RC) , there is a Change Password Tab that does validation on postback. Disable that tab in the dashboard.config file and all the controls on the page will be able to postback.

eg.. Just comment out the following line OR move the comment section to its own dashboard.

 

<!--

 

<tab caption="Change Password">

<control addPanel="true">/umbraco/dashboard/changepassword.ascx</control>

</tab>

 

-->



HTH.

-Isaac

 <!--<tab caption="Change Password"> <control addPanel="true">/umbraco/dashboard/changepassword.ascx</control> </tab>-->
Mar 11, 2011 at 6:37 AM

Cool, it works

I posted your solution to the project page on our.umbraco.org. Hope thats ok.

http://our.umbraco.org/projects/collaboration/ucomment/using-ucomment/17965-Comment-moderation-not-working